WordPress Visual Editor showing blank page or data-mce-type=”bookmark” style=”display eror

Hello Guys,

If you are facing with issue that visual editor is showing blank page or the following code upon clicking on it:

<span data-mce-type=”bookmark” style=”display: inline-block; width: 0px; overflow: hidden; line-height: 0;” class=”mce_SELRES_start”></span>

or if you are little expert and have viewed google chrome developer tool, you might see these errors:

visual-editor-issue-wordpress

 

/wp-content/plugins/ad-invalid-click-protector/assets/css/aicp-admin-interface.min.css?ver=1.0.0:1 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
heartcode-canvasloader-min-0.9.1.js:1 Failed to load resource: the server responded with a status of 404 (Not Found)
load-scripts.php:9 JQMIGRATE: Migrate is installed, version 1.4.1
heartcode-canvasloader-min-0.9.1.js:1 Failed to load resource: the server responded with a status of 404 (Not Found)
popup_icon.gif:1 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-position,jquery-ui-menu,wp-a11y,jquery-ui-autocomplet&load[]=e,moxiejs,plupload&ver=4.9.6:3 Slow network is detected. See https://www.chromestatus.com/feature/5636954674692096 for more details. Fallback font will be used while loading: http://fonts.gstatic.com/s/opensans/v15/mem8YaGs126MiZpBA-UFVZ0b.woff2
post-new.php:1778 WOP Array(1)
plugin.min.js:1 Uncaught TypeError: Cannot read property 'controlManager' of undefined
at n (plugin.min.js:1)
at Object.<anonymous> (plugin.min.js:1)
at b.e [as fire] (tinymce.min.js:6)
at Object.fire (tinymce.min.js:6)
at new q (tinymce.min.js:14)
at g (tinymce.min.js:14)
at Array.<anonymous> (tinymce.min.js:14)
at b (tinymce.min.js:1)
at k (tinymce.min.js:14)
at h.l.bind (tinymce.min.js:1)

 

And you have tried every possible normal routine work to get it fixed like:

– disabled all and reactivated plugins
– changed from theme back to the wordpress default themes
– checked that USER profile settings has viewing of the visual editor unchecked
– used different browsers Chrome and Explorer with no changes
– cleared cache and cookies on both machines (and all browsers)
– logged out and back in to our both accounts
– re-installed latest version of WordPress 4.9.4
– added define(‘CONCATENATE_SCRIPTS’, false); to our wp-config
– tried define( ‘WP_DEBUG’, true );

Visual Editor Fix:

If you have running cache plugin, make sure its cleared, then go to cloudflare settings and try purging everything from there as well. if it works then set your cloudflare settings to default especially caching option which says ignore query string, this must not have been selected.

 

WordPress Visual Editor showing blank page or data-mce-type=”bookmark” style=”display eror
User Rating: 4.9 (1 votes)

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

More in Software, Technology
cloudflare-vs-lets-encrypt
Letsencrypt too many redirects error in wordpress due to cloudflare

As google is launching its new chrome browser, which will force every site owner to use ssl certificate on their...

Close